Intermittent slowness or pages failing to load
Resolved
Jun 12 at 02:46pm HDT
The outage in Google Cloud is mostly resolved, the remaining affected services are not used by YeshID. This incident is now resolved. We apologize for any inconvenience this disruption may have caused
Affected services
Updated
Jun 12 at 12:01pm HDT
Google Cloud engineering has posted an update that they have implemented mitigations and are seeing signs of recovery. They expect recovery to complete within the hour.
Affected services
Created
Jun 12 at 11:13am HDT
Google Cloud Platform, which runs the infrastructure used by YeshID appears to be experiencing an outage: https://status.cloud.google.com. YeshID customers may experience slower page loading times or failed page loads.
Affected services